Jump to content


Photo

Kindle Fire (1st Gen) root/recovery/ROM load

Started by Gman650 ,

  • Sign In To Reply:  

Gman650 #1

Gman650
  • Member
  • Offline
  • 31 posts

Posted Dec 28 '13 @ 11:19 AM

Any suggested paths to Root all the way to CM10.2?



Cyber Warrior #2

Cyber Warrior
  • Robots Will Kill
  • Offline
  • 1500 posts
  • Location: New York
  • Device: GS4 N7

Posted Dec 28 '13 @ 12:01 PM

This will get you going with pretty much everything you'll need before flashing CM (it covers root + recovery + bootloader)... its an auto root program that uses fastboot and adb and has all the included tools zipped up and ready for download: http://forum.xda-dev...d.php?t=2192818

 

CM11 (older builds such as 10.2 are there as well next to the Gapps download): http://forum.xda-dev...d.php?t=1591850

 

If you have any questions feel free to ask... you basically need to download the zip from the first link.. you'll see three download buttons (http://d-h.st/ttL) on the page.. use the middle button and don't install the other crap that it tries to get you to download.. just make sure the Kindle Fire Utility downloads and thats it.  Unzip the folder and click on install_drivers.bat and once that completes.. click on run.bat to start the root tool.


tacsig513.png

: : C  H  A  N  N  E  L   Y  O  U  R    M  E  D  I  A : :


Gman650 #3

Gman650
  • Member
  • Offline
  • 31 posts

Posted Dec 28 '13 @ 9:21 PM

Thanks... I decided on CM10.2 because 11 is still on nightlies. at least there was a Milestone for 10.2.

 

Strange... TWRP seems to have had issues doing Nandroids using their methods. I had to back that out.. put in COTR.. got the Nandroid done and flipped back to TWRP because I THOUGHT I'd do the same as my phone and use GooManager.. however I found that it couldnt send it into recovery mode from the app so I distrusted it and went into TWRP myself.. wiped the caches (etc) and flashed 10.2 w/ Gapps. that seems to have worked well.

 

Anyways.. I installed a few musthaves and then decided to try another Nandroid.. this time the GooManager worked correctly and TWRP got a good snapshot.

 

Ironically.. the kindle app crashes now. Not sure if its the http://goo.im/devs/H...e/otter/cm10.2/ (not being official/stable) or the app itself because there are a LOT of complaints in the review window.



Gman650 #4

Gman650
  • Member
  • Offline
  • 31 posts

Posted Dec 29 '13 @ 9:59 AM

Kindle app has a workaround: http://forum.xda-dev...53#post48928053...

 

Short answer:

download Build.prop Editor from the Play store and using it to change the ro.product.manufacturer line from Amazon to Samsung.


  • Cyber Warrior likes this